好股票网每日提供最新股票软件永利在线娱乐场_永利网上赌场_澳门永利网上赌场_v012.com,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 通达信公式

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2018-08-09 08:45:00
  • 公式评级:
  • 公式类型:通达信公式
  • 授权方式:共享版
  • 公式大小:4.00 KB
  • 解压密码:goodgupiao
  • 永利在线娱乐场_永利网上赌场_澳门永利网上赌场_v012.com统计:
  • 相关Tags:
已有次永利在线娱乐场_永利网上赌场_澳门永利网上赌场_v012.com
推 荐0
不推荐0

自用红色主图 源码 通达信 贴图介绍

好股票软件永利在线娱乐场_永利网上赌场_澳门永利网上赌场_v012.com网(www.goodgupiao.com)提示:您正在永利在线娱乐场_永利网上赌场_澳门永利网上赌场_v012.com的是:自用红色主图 源码 通达信 贴图

自用主图,变红可以关注,买入结合副图,变绿卖出,喜欢的朋友看看,源码奉献。


{参考决策主图}


AVX:=(((((IF(C>MA(C,5),10,(0-10))+IF(MA(C,5)>MA(C,10),10,(0-10)))+IF(C>MA(C,10),10,(0-10)))+IF(MA(C,5)>MA(C,20),10,(0-10)))+IF((C>MA(C,20)),10,(0-10)))+IF

(MA(C,20)>REF(MA(C,20),1),10,(0-10)));

DSLX:=(C/INDEXC);

DSLX1:=MA(DSLX,5);

TJTS1:=BARSTATUS=2 AND C<200;

TJTS2:=BARSTATUS=2 AND C>200;

V1:=MA(V,3);

V2:=MA(V,8);

K2:=HHV(H*0.99,BARSLAST(BARSTATUS=1));

DRAWTEXT_FIX(TJTS1 AND ((CROSS(AVX,1) AND (V1>=V2)) AND (DSLX>=DSLX1)),0.5,0,0,'量能稳定,有走强迹象,根据指数线性关系布局分批介入. '),COLORRED,LINETHICK1;

DRAWTEXT_FIX(TJTS1 AND ((CROSS(AVX,1) AND (V1<V2)) AND (DSLX>=DSLX1)),0.5,0,0,'走势趋强,量能不足,根据指数线性关系布局分批买入. '),COLORRED,LINETHICK1;

DRAWTEXT_FIX(TJTS1 AND ((CROSS(AVX,1) AND (V1>V2)) AND (DSLX<DSLX1)),0.5,0,0,'量价配合良好,没有明显走强,根据指数线性关系考虑进入与否. '),COLORYELLOW,LINETHICK1;

DRAWTEXT_FIX(TJTS1 AND ((CROSS(AVX,1) AND (V1<=V2)) AND (DSLX<DSLX1)),0.5,0,0,'形态尚可,量能不足,未完全走强,根据指数线性关系考虑是否进入. '),COLORGREEN,LINETHICK1;

DRAWTEXT_FIX(TJTS1 AND ((CROSS(1,AVX) AND (V1>=V2)) AND (DSLX>=DSLX1)),0.5,0,0,'形态变坏,减持或者卖出观望. '),COLORGREEN,LINETHICK2;

DRAWTEXT_FIX(TJTS1 AND ((CROSS(1,AVX) AND (V1<V2)) AND (DSLX>=DSLX1)),0.5,0,0,'明显缩量走势,根据指数线性关系减持或清仓,等待机会. '),COLORWHITE,LINETHICK1;

DRAWTEXT_FIX(TJTS1 AND ((CROSS(1,AVX) AND (V1>=V2)) AND (DSLX<DSLX1)),0.5,0,0,'走势偏弱,谨慎操作. '),COLORGREEN,LINETHICK1;

DRAWTEXT_FIX(TJTS1 AND ((CROSS(1,AVX) AND (V1<V2)) AND (DSLX<DSLX1)),0.5,0,0,'缩量下跌,走势偏弱,离场观望. '),COLORGREEN,LINETHICK1;

DRAWTEXT_FIX(TJTS1 AND ((((AVX>=1) AND (REF(AVX,1)>0)) AND (V1>=V2)) AND (DSLX>=DSLX1)),0.5,0,0,'强势明显,量能充足,注意前期平台和指数影响. '),COLORRED,LINETHICK1;

DRAWTEXT_FIX(TJTS1 AND ((((AVX>=1) AND (REF(AVX,1)>0)) AND (V1<V2)) AND (DSLX>=DSLX1)),0.5,0,0,'强势依然,量能转弱,高抛低吸做好布局. '),COLORCYAN,LINETHICK2;

DRAWTEXT_FIX(TJTS1 AND ((((AVX>=1) AND (REF(AVX,1)>0)) AND (V1>=V2)) AND (DSLX<DSLX1)),0.5,0,0,'具备上涨潜力,根据线性关系操作. '),COLORCYAN,LINETHICK2;

DRAWTEXT_FIX(TJTS1 AND ((((AVX>=1) AND (REF(AVX,1)>0)) AND (V1<V2)) AND (DSLX<DSLX1)),0.5,0,0,'走势趋弱,量能不足,减持筹码. '),COLORCYAN,LINETHICK2;

DRAWTEXT_FIX(TJTS1 AND ((((AVX<1) AND (REF(AVX,1)<0)) AND (V1>=V2)) AND (DSLX>=DSLX1)),0.5,0,0,'形态不佳,注意量能变化,跟踪分析确认. '),LINETHICK2;

DRAWTEXT_FIX(TJTS1 AND ((((AVX<1) AND (REF(AVX,1)<0)) AND (V1<V2)) AND (DSLX>=DSLX1)),0.5,0,0,'走势虽弱,关注线性关系和量能变化,确认业绩、题材. '),COLORYELLOW,LINETHICK2;

DRAWTEXT_FIX(TJTS1 AND ((((AVX<1) AND (REF(AVX,1)<0)) AND (V1>=V2)) AND (DSLX<DSLX1)),0.5,0,0,'有走强迹象,上涨压力大,根据大盘情况操作. '),COLORYELLOW,LINETHICK2;

DRAWTEXT_FIX(TJTS1 AND ((((AVX<1) AND (REF(AVX,1)<0)) AND (V1<V2)) AND (DSLX<DSLX1)),0.5,0,0,'走势太弱,整理后关注量能和信号提示. '),LINETHICK2,COLORYELLOW;

DRAWTEXT_FIX(TJTS2 AND (CROSS(AVX,1) AND (V1>=V2)),0.5,0,0,'量能稳定,有明显走强迹象,可以考虑布局. '),COLORWHITE,LINETHICK2;

DRAWTEXT_FIX(TJTS2 AND (CROSS(AVX,1) AND (V1>=V2)),0.5,0,0,'如前期经过一轮下跌,此时为最佳买点,但前期有过一段涨幅则介入需谨慎. '),COLORWHITE,LINETHICK2;

DRAWTEXT_FIX(TJTS2 AND (CROSS(AVX,1) AND (V1<V2)),0.5,0,0,'虽然走势趋强,量能还显不足,根据线性关系操作. '),COLORWHITE,LINETHICK2;

DRAWTEXT_FIX(TJTS2 AND (CROSS(AVX,1) AND (V1<V2)),0.5,0,0,' 可以谨慎布局,控制仓位,一旦量能放大可以重仓买入. '),COLORWHITE,LINETHICK2;

DRAWTEXT_FIX(TJTS2 AND (CROSS(1,AVX) AND (V1>=V2)),0.5,0,0,'大盘形态走坏,减仓或者抛光. '),COLORGREEN,LINETHICK2;

DRAWTEXT_FIX(TJTS2 AND (CROSS(1,AVX) AND (V1<V2)),0.5,0,0,'弱势缩量调整,清仓观望,寻找可布局股票. '),COLORWHITE,LINETHICK2;

DRAWTEXT_FIX(TJTS2 AND (((AVX>=1) AND (REF(AVX,1)>0)) AND (V1>=V2)),0.5,0,0,'走势良好,量能稳定,可以继续持有强势股. '),COLORWHITE,LINETHICK2;

DRAWTEXT_FIX(TJTS2 AND (((AVX>=1) AND (REF(AVX,1)>0)) AND (V1<V2)),0.5,0,0,'形态良好,量能稍显不足,线性关系顶部背离,随时准备清仓. '),COLORWHITE,LINETHICK2;

DRAWTEXT_FIX(TJTS2 AND (((AVX<1) AND (REF(AVX,1)<0)) AND (V1>=V2)),0.5,0,0,'趋势不明,注意量能和线性关系变化,减少操作. '),LINETHICK2,COLORWHITE;

DRAWTEXT_FIX(TJTS2 AND (((AVX<1) AND (REF(AVX,1)<0)) AND (V1<V2)),0.5,0,0,'趋势向下,量能萎缩,关注线性关系变化,减少操作. '),LINETHICK2,COLORWHITE;

RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;

K1:=SMA(RSV,3,1);

D1:=SMA(K1,3,1);

高1:=HHV(H,150);

低1:=LLV(L,150);

QR:=(H+L+2*C)/4;

强弱分界线:=EMA(QR,55),COLORFFFF00;

TFXXS:=INTPART(K1)+INTPART(D1);

TGL:=(TFXXS-REF(TFXXS,1));

DRAWTEXT_FIX(ISLASTBAR AND TGL>=0 AND TGL>REF(TGL,1),0.99,0.01,1,'资金状况:流入加快'),COLOR0202FF;

DRAWTEXT_FIX(ISLASTBAR AND TGL>=0 AND TGL<=REF(TGL,1),0.99,0.01,1,'资金状况:流入减慢'),COLOR1876E9;

DRAWTEXT_FIX(ISLASTBAR AND TGL<0 AND TGL>REF(TGL,1),0.99,0.01,1,'资金状况:流出减慢'),COLOR13B79A;

DRAWTEXT_FIX(ISLASTBAR AND TGL<0 AND TGL<=REF(TGL,1),0.99,0.01,1,'资金状况:流出加快'),COLOR00CA00;

VAR1E:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);

VAR2E:=SMA(ABS(LOW-VAR1E),13,1)/SMA(MAX(LOW-VAR1E,0),10,1);

VAR3E:=EMA(VAR2E,10);

VAR4E:=LLV(LOW,33);

VAR5E:=EMA(IF(LOW<=VAR4E,VAR3E,0),3);

VAR21E:=SMA(ABS(HIGH-VAR1E),13,1)/SMA(MIN(HIGH-VAR1E,0),10,1);

VAR31E:=EMA(VAR21E,10);

VAR41E:=HHV(HIGH,33);

VAR51E:=EMA(IF(HIGH>=VAR41E,VAR31E,0),3);

DRAWTEXT_FIX(ISLASTBAR AND VAR51E<REF(VAR51E,1),0.99,0.08,1,'主力正在拉高'),COLOR0202FF;

DRAWTEXT_FIX(ISLASTBAR AND VAR5E>REF(VAR5E,1),0.99,0.15,1,'典型吸筹行为'),COLOR1876E9;

DRAWTEXT_FIX(ISLASTBAR AND VAR5E<REF(VAR5E,1),0.99,0.15,1,'典型洗盘行为'),COLORC08000;

DRAWTEXT_FIX(ISLASTBAR AND VAR5E=REF(VAR5E,1),0.99,0.15,1,'无特殊行为'),COLORC0C0C0;

DRAWTEXT_FIX(ISLASTBAR AND VAR51E>REF(VAR51E,1),0.99,0.08,1,'主力正在出货'),COLOR00CA00;

DRAWTEXT_FIX(ISLASTBAR AND VAR51E=REF(VAR51E,1),0.99,0.08,1,'主力无大动作'),COLORC0C0C0;


{拉升潜力}

VAR78:=C/EXPMA(C,5);

A1:=COST(1.91);

A2:=COST(3.82);

A3:=COST(5);

A4:=COST(6.18);

A5:=COST(8.09);

COSTT:=(A1+A2+A3+A4+A5)/5;

COSTT1:=C/COSTT;

VARD1:=(2*INDEXC+INDEXH+INDEXL)/4;

VARD2:=LLV(INDEXL,21);

VARD3:=HHV(INDEXH,8);

MIJI:=EMA((VARD1-VARD2)/(VARD3-VARD2)*100,9);

MIJI1:=MIJI-VAR78;

MIJI2:=MIJI1-REF(MIJI1,1);

MIJI3:=MIJI-REF(MIJI,1);

DAPAN:=COSTT1-(MIJI3+0.618*MIJI2)/16.18;

DRAWTEXT_FIX(ISLASTBAR AND DAPAN<COSTT1,0.99,0.8,1,'受大盘拉动'),COLOR0202FF;

DRAWTEXT_FIX(ISLASTBAR AND DAPAN>=COSTT1,0.99,0.8,1,'受大盘压制'),COLOR00CA00;


X1E:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;

X2E:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;

X3E:=FINANCE(23)/FINANCE(10)*3.3;

X4E:=FINANCE(19)/FINANCE(15)*0.6;

X5E:=FINANCE(20)/FINANCE(15)*0.999;

YAOGU:=X1E+X2E+X3E+X4E+X5E;

XJF:=CON2STR(FINANCE(25)/FINANCE(15),3);

YZZ:=CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2);

DRAWTEXT_FIX(YAOGU<=0,0.99,0.99,1,'拉升潜力:难于登天'),COLOR00FF00;

DRAWTEXT_FIX(YAOGU>0 AND YAOGU<=1.2,0.99,0.99,1,'拉升潜力:难度较大'),COLOR3A8B5C;

DRAWTEXT_FIX(YAOGU>1.2 AND YAOGU<=2.6,0.99,0.99,1,'拉升潜力:尚可一试'),COLOR4747B8;

DRAWTEXT_FIX(YAOGU>2.6 AND YAOGU<=5.8,0.99,0.99,1,'拉升潜力:较为容易'),COLOR2424DB;

DRAWTEXT_FIX(YAOGU>5.8,0.99,0.99,1,'拉升潜力:轻而易举'),COLOR0000FF;


DRAWTEXT_FIX(XJF>=1618,0.99,0.86,1,'过于保守'),COLOR4747B8;

DRAWTEXT_FIX(XJF>=618 AND XJF<1618,0.99,0.86,1,'保守求稳'),COLOR4747B8;

DRAWTEXT_FIX(XJF>=100 AND XJF<618,0.99,0.86,1,'收支平衡'),,COLOR0000FF;

DRAWTEXT_FIX(XJF<100,0.99,0.86,1,'负债过多'),COLOR00FF00;

DRAWTEXT_FIX(YZZ<85,0.99,0.86,1,'资产质地差'),COLOR00FF00;


快线:=EMA(C,7)-EMA(C,21),LINETHICK2,COLORRED;

慢线:=MA(快线,4),COLORGREEN,LINETHICK2;

数值:=EMA((0.668*REF(快线,1)+0.333*快线),1),COLORSTICK;

X1:=V/SUM(V,13);

X2:=DMA(C,X1);

X3:=(C-X2)/X2*40;

L2:=MA(AMOUNT/(100*V),13);

CYS13:= (C-L2)/L2*100;

做多:=IF(快线>=数值,快线,数值);

做空:=IF(数值-快线,数值,快线);

强庄:STICKLINE(CYS13>5,L-0.22,L-0.35,2,0),COLORCYAN;

AAA:=(3*C+H+L+O)/6;

VAR1:(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36,LINETHICK2,COLORRED;

VAR2:=(HHV(VAR1,2)+HHV(VAR1,4)+HHV(VAR1,8))/0;

VAR3:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;

VAR4:=(HHV(VAR2,2)+HHV(VAR2,4)+HHV(VAR2,8))/0;

VAR5:(LLV(VAR3,2)+LLV(VAR3,4)+LLV(VAR3,8))/3,COLORRED;

VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;

{DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));}

IF((VAR1 <= REF(VAR1,1)),VAR1,DRAWNULL),COLORGREEN,LINETHICK3;

IF((VAR1 >= REF(VAR1,1)),VAR1,DRAWNULL),COLORRED,LINETHICK3;

STICKLINE(VAR4>VAR1,VAR4,VAR1,0,0),COLORBLUE;

DRAWKLINE(H,O,L,C);

DRAWTEXT(REF(VAR5,1)=REF(VAR1,1) AND VAR5<VAR1,L*0.99,'↖买入'),COLORYELLOW;

DRAWTEXT(REF(VAR6,1)=REF(VAR1,1) AND VAR6<VAR1,L*0.98,'↖加仓'),COLORYELLOW;


CC:=((HIGH+LOW+CLOSE)/3-EMA((HIGH+LOW+CLOSE)/3,5))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,5));

STICKLINE(CC>=0,LOW,HIGH,0.0,0),COLORRED;

STICKLINE(CC>=0,CLOSE,OPEN,3,1),COLORRED;

STICKLINE(CC<0,LOW,HIGH,0.0,0),COLORGREEN;

STICKLINE(CC<0,CLOSE,OPEN,3,1),COLORGREEN;


月DI:="MACD.DIF#MONTH";

月DE:="MACD.DEA#MONTH";

周DI:="MACD.DIF#WEEK";

周DE:="MACD.DEA#WEEK";

日DI:="MACD.DIF";

日DE:="MACD.DEA";

日金叉:=CROSS(日DI,日DE);

周金叉:=CROSS(周DI,周DE);

月金叉:=CROSS(月DI,月DE);

日穿0:=CROSS(日DI,0);

周穿0:=CROSS(周DI,0);

月穿0:=CROSS(月DI,0);

DRAWTEXT(日穿0,LOW-0.48,'↖日穿0'),COLORCYAN;

DRAWTEXT(周穿0,L*0.94,'↖周穿0'),COLORCYAN;

DRAWTEXT(月穿0,L*0.99,'↖月穿0'),COLORCYAN;

DRAWTEXT(日金叉,LOW-0.3,'↖日金叉'),COLORCYAN;

DRAWTEXT(周金叉,L*0.92,'↖周金叉'),COLORCYAN;

DRAWTEXT(月金叉,L*0.90,'↖月金叉'),COLORCYAN;


{穿三线}

MA2:=EMA(C,2);

MA05:=EMA(C,5);

MA010:=EMA(C,10);

MA020:=EMA(C,20);

MA030:=EMA(C,30);

YC0X:=MA05>=REF(MA05,1);

H01:=MAX(MAX(MA05,MA010),MA020);

L01:=MIN(MIN(MA05,MA010),MA020);

一穿三线:=H01<C AND O<L01 AND YC0X AND MA2>REF(MA2,1);

STICKLINE(一穿三线,O,C,0.3,0),COLORYELLOW;

DRAWTEXT(一穿三线,L-0.62, '←穿三线'),COLORGREEN;
 

{资金净流入监控}

总额:=AMOUNT;

买A:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));

买%:=买A/AMOUNT*100;

流入:=AMOUNT*买%/10000000000;

流出:=AMOUNT/100000000-流入;

净流:=(流入-流出);

总额3:=SUM(AMOUNT,3);

流入3:=SUM(流入,3);

流出3:=SUM(流出,3);

净流3:=SUM(流入-流出,3);

总额5:=SUM(AMOUNT,5);

流入5:=SUM(流入,5);

流出5:=SUM(流出,5);

净流5:=SUM(流入-流出,5);

总额10:=SUM(AMOUNT,10);

流入10:=SUM(流入,10);

流出10:=SUM(流出,10);

净流10:=SUM(流入-流出,10);

画:=CONST(FINDHIGH(总额10,0,190,1));

DRAWTEXT_FIX(1,0,0.37,0,'净流(亿):'),COLORMAGENTA,LINETHICK1;

DRAWTEXT_FIX(1,0,0.45,0,'1日'),COLORMAGENTA,LINETHICK1;

DRAWTEXT_FIX(1,0,0.55,0,'3日'),COLORMAGENTA,LINETHICK1;

DRAWTEXT_FIX(1,0,0.65,0,'5日'),COLORMAGENTA,LINETHICK1;

DRAWTEXT_FIX(1,0,0.75,0,'10日'),COLORMAGENTA,LINETHICK1;

DRAWNUMBER_FIX(1,0.05,0.45,0,CONST((净流))),COLORYELLOW;

DRAWNUMBER_FIX(1,0.05,0.55,0,CONST((净流3))),COLORYELLOW;

DRAWNUMBER_FIX(1,0.05,0.65,0,CONST((净流5))),COLORYELLOW;

DRAWNUMBER_FIX(1,0.05,0.75,0,CONST((净流10))),COLORYELLOW;





好股票软件永利在线娱乐场_永利网上赌场_澳门永利网上赌场_v012.com网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
自用红色主图 源码 通达信 贴图永利在线娱乐场_永利网上赌场_澳门永利网上赌场_v012.com澳门永利网上赌场
相关说明
  • 好股票软件永利在线娱乐场_永利网上赌场_澳门永利网上赌场_v012.com网欢迎用户将网页内容和永利在线娱乐场_永利网上赌场_澳门永利网上赌场_v012.com澳门永利网上赌场转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现永利在线娱乐场_永利网上赌场_澳门永利网上赌场_v012.com链接错误,请点击报告错误谢谢!